Page 41 of 41 FirstFirst ... 313738394041
Results 401 to 404 of 404

Thread: The big TEC driver thread!

  1. #401
    Join Date
    Feb 2011
    Location
    New Hampshire
    Posts
    3,508

    Default

    Dave,

    Thanks for the link. Very interesting site. He does seem to have "some skills".

  2. #402
    Join Date
    Nov 2005
    Location
    Melbourne, Australia
    Posts
    3,654

    Default

    The Arduino post by Wolfgang inspired me to start tinkering with the project i began on an Atmel XMEGA ages ago.

    Previously, I had ported the Arduino PID code to the xmega, today I got the NTC front end working. Tomorrow Ill try to get the PWM working... Maybe

    IMG_9418.JPGIMG_9417.JPG
    KVANT Australian projector sales
    https://www.facebook.com/kvantaus/

    Lasershowparts- Laser Parts at great prices
    https://www.facebook.com/lasershowparts/

  3. #403
    Join Date
    Jan 2006
    Location
    Switzerland
    Posts
    129

    Default

    I will post my Arduino software soon, I had to rewrite a lot, esp interfacing via USB to tty and LabVIEW. This is now pretty final but almost nothing is done for the LD driver. I am looking into a low noise setup, perhaps involving those ultra-low noise Zeners 2DW232 I had been studying for a while. But low noise and "PWM" (for TEC) are an inherent contradiction, so that remains to be seen..

    Nice work Dave1

  4. #404

    Default

    Oh, I see this thread is back to life ))
    I suspect that my driver was born prematurely, it has linear h-bridge TEC section and uart interface, but I deliberately did not use digital temperature sensors there. So it was just an ordinary TEC controller

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •