Results 1 to 3 of 3

Thread: no laser output in quickshow

  1. #1
    Join Date
    Aug 2010

    Default no laser output in quickshow

    This is my first post and first problem. Iíve luv this forum it got me as far as I amÖ.

    I have built an rgb system using an array of cheap lasers and galvos. Iím using pt-30k scanners with the pt-itrust board. When itís running off the itrust board i auto-mode all the lasers fire and blanks correctly. The problem is when I run quickshow the galvos run but lasers donít. Iíve tried running the blanking and galvos directly off the fb3 (bypassing the itrust board altogether) by soldering my own connector red pin 5/18 green pin 6/19 blue pin 7/20 the galvos still work, lasers donít. Iím running a flexmod v3 on my blue, a green gpx-1000, and a r-1000 for lasers if this info helps. And yes Iíve activated laser output on qs.
    I canít figure out why none come on. There are 3 different manufacturers of lasers at least one should work. Iíve even tried grounding the Ė outputs and reversing -/+Ö When I disconnect all lasers come on. What Iím I doing wrong

  2. #2
    Join Date
    Jul 2009
    The Netherlands


    Maybe the PT itrust board expects the interlock loop 4-17 to be closed ?
    I had some weird funny shit with the pt itrust board as well, hence i threw it out.

    Sometimes it started up in auto mode, and i wanted it to look at the ilda connection, which it didn't. Make sure to use a fully wired cable (so the interlock is seen as closed when the FB3 is connected on the other end).
    This is what i can think of, there is also a keylock connection on the itrust, is that also closed ?
    I didn't fail !
    I just found out 10,000 ways that didn't work.

  3. #3
    Join Date
    Aug 2010


    Thank you for the response, I’ve read so many things from you. anyways,
    The keylock pins are shorted on the itrust board. The itrust board run the system perfect by itself.
    as soon as i plug the the fb3 in it stops automode and the scanners are directly controlled by the computer, just no lasers i tried with a full though cable..
    the peice i soldered up was connected directly from the fb3 to the scanners and lasers.
    On the fb3 the only wires really needed to test this “without” the itrust board is the x/y -/+ and the red/green/blue ttl wires.. Would I be correct with this?

    if so the lasers still do not come on..
    Last edited by grasshopper; 10-10-2010 at 11:02.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts