Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ALC68 and Meditec HELP Please

  1. #1
    Join Date
    Oct 2010
    Location
    Wiltshire, UK
    Posts
    579

    Default ALC68 and Meditec HELP Please

    Hi all
    I have recently purchased the above system and posted on here, im in need of your help
    I have set the laser up now with a 32a supply after the previous owner used to run it on a UK 13a plug, I have no control of the output amps and it can show upto 40a whilst running, obviously I shut it down straight away as I don't want to cause damage. Im looking for advice if anyone has had a similar problem. Im thinking of rebuilding the power supply/ transistor bank. Does anyone have any schematics for this system, anything that may help me work out whats going on with it. Your help would be muck appreciated.

    Whilst on the subject can anyone advise me if there is a laser meet at some point in the UK, I live in Wiltshire and dont mind bit of travelling to have a look at some of the systems you use, and meet everyone.
    Thanks Tony

  2. #2
    mixedgas's Avatar
    mixedgas is offline Creaky Old Award Winning Bastard Technologist
    Infinitus Excellentia Ion Laser Dominatus
    Join Date
    May 2007
    Location
    A lab with some dripping water on the floor.
    Posts
    9,186

    Default

    Shoot me a pic of the inside of the supply, 50/50 chance I have the schematic.

    steve

  3. #3
    Join Date
    Jun 2008
    Location
    Yellowknife, NT, Canada
    Posts
    2,147,484,113

    Default

    Quote Originally Posted by tonyaztec View Post
    Hi all
    I have recently purchased the above system and posted on here, im in need of your help
    I have set the laser up now with a 32a supply after the previous owner used to run it on a UK 13a plug, I have no control of the output amps and it can show upto 40a whilst running, obviously I shut it down straight away as I don't want to cause damage. Im looking for advice if anyone has had a similar problem. Im thinking of rebuilding the power supply/ transistor bank. Does anyone have any schematics for this system, anything that may help me work out whats going on with it. Your help would be muck appreciated.

    Whilst on the subject can anyone advise me if there is a laser meet at some point in the UK, I live in Wiltshire and dont mind bit of travelling to have a look at some of the systems you use, and meet everyone.
    Thanks Tony

    http://www.photonlexicon.com/forums/...West-Yorkshire...

    http://www.photonlexicon.com/forums/...-of-April-2011


    Have a look at those two threads, both about upcoming meets.

  4. #4
    Join Date
    Oct 2010
    Location
    Wiltshire, UK
    Posts
    579

    Cool

    Thanks Diachi, I will try to attend one of the meets you have suggested, and Steve I will borrow the wife's camera to get some photos of the power supply as im keen to get the laser running as it should.

    Cheers Tony

  5. #5
    Join Date
    Oct 2010
    Location
    Wiltshire, UK
    Posts
    579

    Thumbs up Photos.

    I have no attached some photos of the laser and power supply, as you can see its bit of a mess as its been stood for some time, I would eventually rebuild, restore them in time once I have confirmed the unit is good.
    Thanks for you help.

    Tony
    Attached Thumbnails Attached Thumbnails P1010940.JPG  

    P1010944.JPG  

    P1010942.JPG  

    P1010946.JPG  

    P1010943.JPG  

    P1010945.JPG  

    P1010939.JPG  

    P1010941.JPG  


  6. #6
    Join Date
    Apr 2005
    Location
    SOUTHAMPTON U.K.
    Posts
    1,357

    Default

    Thats one of my old 68's. I know this, because I painted the lid black and put a strip of gaffa tape across the panel joint to stop air leaks. It was very clean when I last saw it and didnt have any rust.

    I sent it to Sid Kamani at Universal Lasers because one of the cathode connectors had snapped off the tube. He has going to TIG weld it and regas the tube. I paid a grand up front and never saw it again.

    It looks like he has fitted a new tube and using a different power supply though. I can also describe the modifications I made to the supply in order to identify it.

  7. #7
    Join Date
    Oct 2010
    Location
    Wiltshire, UK
    Posts
    579

    Default

    Hi Quazar, I dont know what to say, I bought the unit legit from a guy in Birmingham after I saw it on ebay. I did bid for the laser but lost it it the last minuet, I chased the guy after he left feedback to the seller. The guy he bought it from told him that it was once owned by a guy at Laserelectronics. Im pleased to say that I always keep a record of sales on email should things go pear shaped.

    Tony

  8. #8
    Join Date
    Apr 2005
    Location
    SOUTHAMPTON U.K.
    Posts
    1,357

    Default

    Hi Tony. I have no gripe against you as you obviously purchased it in good faith. I am not going to try and relcaim it either.

    I am just pissed with Sid, as once he got my money, he refused to return my calls. Anyway, this was almost 10 years ago now and I am (almost) over it. From what I have gathered, Sid dissappeared abroad 7 or 8 years ago.

    I expect Sid probably swapped the tube out and put it in a club somewhere until he moved

  9. #9
    mixedgas's Avatar
    mixedgas is offline Creaky Old Award Winning Bastard Technologist
    Infinitus Excellentia Ion Laser Dominatus
    Join Date
    May 2007
    Location
    A lab with some dripping water on the floor.
    Posts
    9,186

    Default

    Ok, I have a schematic for that.

    There is a ascii mod text for it too, as it has a weird PWM input on the back until modded.

    Mod is not hard, consists of moving a few wires and adding a current pot.

    Use of the PWM is tricky, so do the mod.

    I just sold my last one of those to a PLer, and I have PMed you with his name, he had no trouble reverse engineering it and can send you pics of my mod.

    Steve

  10. #10
    Join Date
    Oct 2010
    Location
    Wiltshire, UK
    Posts
    579

    Default

    Thanks Quazar, last thing I want is to start upsetting people, Its bad when you have put your trust in someone and they let you down in that way.

    Steve, Thanks for your PM, I have sent a message to him and hopefully we can get this unit usable again.

    Cheers Tony

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •