Results 1 to 3 of 3

Thread: CNI 2000mw 532nM DPSS slow to warm up

  1. #1
    Join Date
    Dec 2011
    Location
    luton
    Posts
    57

    Default CNI 2000mw 532nM DPSS slow to warm up

    Hello all,

    I have a couple of RGB projectors that contain as the green source a 2W CNI dpss module. One of the projectors operates properly immediately with the green giving full output and a clean beam from the outset - but the other does not behave in the same way.

    The problem unit will not come up to full power until it has been on and emitting some content with a full power / constant green signal for a few minutes. Its rather like a discharge lamp warming up - it does produce some output immediately and the beam looks reasonably clean but as said it does take some time for anything close to full power to be emitted.

    If the laser is rested again for a few mins, the problem returns.

    The slow warm up is less pronounced when the ambient temperature is higher, so I'm guessing this is a simple-ish temperature issue, as i have read that DPSS units are quite temperature fussy.

    In short, whilst i am confident in building projectors, and even re-aligning diode based modules whose internal alignment has slipped, I'm not sure if, with my current knowledge i am happy to deal with this. Who in the UK, preferably south east / midlands would be good to talk to / look at the issue?

    Many thanks
    Chris

  2. #2
    Join Date
    Jul 2007
    Location
    west sussex uk
    Posts
    2,279

    Default

    Sounds like it needs a Tec tune up ,Rob aka stanwax is the man for that job.
    When God said “Let there be light” he surely must have meant perfectly coherent light.

  3. #3
    Join Date
    Dec 2011
    Location
    luton
    Posts
    57

    Default

    great, thank you - ill contact him

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •