Results 1 to 8 of 8

Thread: DT amp problem

  1. #1
    Join Date
    Feb 2008
    Location
    East Sussex, England
    Posts
    5,137

    Default DT amp problem

    Hi

    I've just taken delivery of 2 more sets of DT30, and one of the amps appears to not work.

    I have swapped input signal to the good amp, and it drives both galvos fine (so both galvos are confirmed working on the good amp)
    When I take the signal from the bad amp and plug it into the good amp, the good amp works fine.
    When I take the good signal from the good amp and plug it into the bad amp, it doesn't work.

    The bad amp has 2 steady green LEDs just like the good amp.

    Also, the galvo fixed solid straight ahead when driven by the amp, so it is getting power. It's just not getting a signal by the look of it.

    I'm not sure I have time to get another amp in time for a show now, so I need to see if this is something I could look at myself.
    http://www.facebook.com/SubsonicSystems
    http://www.frikkinlazors.co.uk

    You are using Bonetti's defense against me, ah?

    I thought it fitting, considering the rocky terrain.

  2. #2
    Join Date
    Feb 2008
    Location
    Northern Indiana
    Posts
    882

    Default

    If the galvo "stiffens up" when power is applied the optical feedback is working. I would "jiggle" or apply pressure with a finger to the pots and other components near the input connector. Maybe with luck its a loose solder joint and you may find it that way. Next would be to put the same signal to the bad and good amp and use a scope to trace the signal starting at the input connector until it stops. Using the good amp as a reference for what to look for.

  3. #3
    Join Date
    May 2006
    Location
    Native Floridian
    Posts
    3,083

    Default

    Could the image size pots be turned all the way down? I don't remember which pot is which or if it's labelled.

  4. #4
    swamidog's Avatar
    swamidog is online now Jr. Woodchuckington Janitor III, Esq.
    Join Date
    Nov 2006
    Location
    santa fe, nm
    Posts
    1,545,276

    Default

    Quote Originally Posted by DZ View Post
    Could the image size pots be turned all the way down? I don't remember which pot is which or if it's labelled.
    i think this is right, but make no promises.

    Click image for larger version. 

Name:	dt40w-pots.jpg 
Views:	29 
Size:	340.3 KB 
ID:	43016
    suppose you're thinkin' about a plate o' shrimp. Suddenly someone'll say, like, plate, or shrimp, or plate o' shrimp out of the blue, no explanation. No point in lookin' for one, either. It's all part of a cosmic unconciousness.

  5. #5
    Join Date
    May 2007
    Location
    Authentic Asian food area of SoCal
    Posts
    2,382

    Default

    Quote Originally Posted by swamidog View Post
    i think this is right, but make no promises.

    Click image for larger version. 

Name:	dt40w-pots.jpg 
Views:	29 
Size:	340.3 KB 
ID:	43016
    I think that's almost right. This was sent to me a while ago from Dave:

    Click image for larger version. 

Name:	dt3.JPG 
Views:	23 
Size:	463.8 KB 
ID:	43017

  6. #6
    Join Date
    Nov 2005
    Location
    Melbourne, Australia
    Posts
    3,693

    Default

    The invert jumpers are fitted?
    KVANT Australian projector sales
    https://www.facebook.com/kvantaus/

    Lasershowparts- Laser Parts at great prices
    https://www.facebook.com/lasershowparts/

  7. #7
    Join Date
    Feb 2008
    Location
    East Sussex, England
    Posts
    5,137

    Default

    Could the image size pots be turned all the way down? I don't remember which pot is which or if it's labelled.
    Very nearly totally the problem!

    I turned the scale pot and the image magically jumped back into life! Turn it back again, nothing, so its actually a dodgy pot, rather than just turned down.

    I have about 8 of the daughter boards here that are redundant now I have 506's ina lot of projectors, so I'm hoping one of the pots on there is the correect value.
    http://www.facebook.com/SubsonicSystems
    http://www.frikkinlazors.co.uk

    You are using Bonetti's defense against me, ah?

    I thought it fitting, considering the rocky terrain.

  8. #8
    Join Date
    Feb 2008
    Location
    East Sussex, England
    Posts
    5,137

    Default

    All sorted, thanks very much chaps!
    http://www.facebook.com/SubsonicSystems
    http://www.frikkinlazors.co.uk

    You are using Bonetti's defense against me, ah?

    I thought it fitting, considering the rocky terrain.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •