Results 1 to 7 of 7

Thread: Lasever LSR473ML-100 Power Rating

  1. #1
    Join Date
    Jul 2014
    Posts
    4

    Laser Warning Lasever LSR473ML-100 Power Rating

    Hi,

    i got a Lasever LSR473ML-100, and I'm surprised how much current it draws (with the Lasever PS1): 4.5 Amps after the TEC starts running. Is this normal?
    Would be very grateful if somebody knows...

    Best,
    Michael

  2. #2
    Join Date
    Apr 2009
    Location
    Zürich-Bangkok-Dubai
    Posts
    275

    Default

    Im not sure but from what I know is that blue dpss (473nm) are not efficient from its lower gain material (BBO or LBO ) tends to have a efficiency of 3-5%
    So I think its normal that it draw over 4Amps for a 100mW output, I could be wrong :P
    Philipp Wetter

  3. #3
    Join Date
    Jul 2014
    Posts
    4

    Default

    I guess a lot of the current might be from the TEC. Not sure if the if the diode draws so much. But it could be...

  4. #4
    Join Date
    Apr 2009
    Location
    Zürich-Bangkok-Dubai
    Posts
    275

    Default

    Quote Originally Posted by biolippi View Post
    I guess a lot of the current might be from the TEC. Not sure if the if the diode draws so much. But it could be...
    That too, but tec shouldn't draw much current once the temp has been stabilized but yea it does draw alot current too, again depending on the load, output power etc...
    Philipp Wetter

  5. #5
    Join Date
    Mar 2010
    Location
    Raleigh, NC
    Posts
    2,156

    Default

    Quote Originally Posted by biolippi View Post
    Hi,

    i got a Lasever LSR473ML-100, and I'm surprised how much current it draws (with the Lasever PS1): 4.5 Amps after the TEC starts running. Is this normal?
    Would be very grateful if somebody knows...

    Best,
    Michael
    I have found that after about 6 months it is normal for the lasever 473nm modules to draw a lot of current a put out very little laser power. I hope you are luckier than me. I had two of them die.

  6. #6
    Join Date
    Jul 2014
    Posts
    4

    Default

    The output is correct at 100 mW. What do you mean by a lot of current? Would 4 Amps be unreasonable?

  7. #7
    Join Date
    Apr 2009
    Location
    Zürich-Bangkok-Dubai
    Posts
    275

    Default

    Another contribution to low output or dead is with some 473nm dpss using BBO or LBO which are know to be hygroscopic which attract moisture therefore degrading the crystal,
    not sure but a better substitute would be BiBO, dont know which manufacture use which crystal
    Philipp Wetter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •