Results 1 to 5 of 5

Thread: Looking for a new hazer

  1. #1
    Join Date
    Aug 2005
    Location
    Silicon Valley
    Posts
    440

    Default Looking for a new hazer

    Looks like my old Elektralite Turbohaze has finally bitten the dust. It was sputtering pretty badly at the last show I did and now that I've gotten it out to try and do the vinegar and water cleanout bit, it seems to be mostly dead. It heats up, but never goes ready so I can't even try to make haze or pump cleaning solution through the heater.

    So I'm looking for suggestions on a decent replacement. I'd like to keep it under $500, preferably with a road case and since I do the occasional outdoor show, something fairly high volume would be best. What's the state of the art in glycol vaporizing technology these days?

  2. #2
    Join Date
    Aug 2005
    Location
    Silicon Valley
    Posts
    440

    Default

    Seems my hazer was made by Antari and is the same as their Z-300. I pulled the controller board out and fussed with it a bit (reseated the microcontroller chip and touched up a few sketchy looking solder joints) and it's at least trying to run again. It gets nice and hot and the pump makes a bit of noise (ticking at a variable rate according to where the volume knob is set on the remote). But it's still just putting out a tiny amount of steam with occasional small spurts of haze.

    I pulled the output tube off of the pump and checked for flow. It's barely flowing, but that probably makes sense since it's supposed to last an hour or 2 on the liter of fluid in the tank. I'm going to let it run with the vinegar / water fluid and hope things improve.

    Anyone out there fixed a hazer before? Bad pump? Bad heater? Bad whatever it is that's getting heated?

  3. #3
    Join Date
    Aug 2005
    Location
    Silicon Valley
    Posts
    440

    Default

    Pretty sure it's a bad pump. Watched a video of a guy who had a similar problem and his new replacement pump flow rate is about 100x mine. Found and ordered what is likely the very last of these pumps on the planet. Should be here in a few days, plenty of time to get the old girl back in working order before the next big event here on the 27th. A 2 day music festival in the Redwood forest near Boulder Creek if anyone is interested...

  4. #4
    Join Date
    Aug 2005
    Location
    Silicon Valley
    Posts
    440

    Default

    Not that anyone cares, but I figured I wrap this up by reporting that I got the replacement pump, installed it and my hazer is working like new! On the odd chance anyone else needs a replacement pump, here's what I ordered.

    https://parts.elationlighting.com/Pr...ine=Z-300%20II

  5. #5
    Join Date
    Aug 2008
    Location
    UK
    Posts
    5,704

    Default

    Good result.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •