Results 1 to 6 of 6

Thread: Help finding raplacement PSU for GS galvos.

  1. #1
    Join Date
    Mar 2013
    Location
    Langhus - Norway
    Posts
    345

    Default Help finding raplacement PSU for GS galvos.

    I have a feeling that the powersupply in my cheap, (but beloved) single brick RGB PJ have problems. I`m not depply into electronics, and having problems finding the correct replacement PSU. The Galvos are from Goldenstar Lasers. Some of you have probably gotten the 25k set from them due to the low price. For six tendollar bills, i have found the value for money more than good for bulding a beam-machine.

    The problem:
    When powering up the PJ, the Galvos start clicking, and moves randomly. The red LED`s on both galvo controllers in the same clicking rate, and actually also the led inside the PSU.

    When hooking off the Y side, and powering up, i get a nice line, and the galvo sounds normal.

    I also got the "not so good" smell of burned electronics, but have not been able to locate from where yet.

    I have taken all major components apart to eliminate grounding issues.

    But, i`m suspecting the powersupply to be the problem. The powersupply have written on it +15V -15V and GND.

    A tip on what to search for would be highly apreciated.

    Espen
    __________________________________________________ __________

    More projects than time available.
    More projects started than finished.
    More money spent than earned.
    More failure than success.
    Just got to love lasers!

  2. #2
    Join Date
    Apr 2007
    Location
    Costa Rica
    Posts
    523

    Default

    Do you have a voltmeter to measure the actual output of the supplies (under a load)? Also, it would be nice if you could view the power supplies output on a scope to make sure they are producing a smooth pure DC (under load). If you remove the XY signals from the scanners are they stable? Inspect all connectors and solder joints.

  3. #3
    Join Date
    Mar 2013
    Location
    Langhus - Norway
    Posts
    345

    Default

    Without load, the PSU deliveres +15.5 and -15,3 steady.

    I hooked up everything again, and guess what. It worked. - but, as soon as i touched the controllercard for the Y galvo it started to pulse again.
    Off and on again, and it works. No touch = OK

    Touch it and it starting to pulse. I guess I in for locating the point of bad soldering.

    Thanks for your quick reply Photonbeam!


    Espen
    __________________________________________________ __________

    More projects than time available.
    More projects started than finished.
    More money spent than earned.
    More failure than success.
    Just got to love lasers!

  4. #4
    Join Date
    Oct 2007
    Location
    Wisconsin
    Posts
    305

    Default

    take a plastic comb and slowly go across the solder joints and look for the intermittent to happen and try to see which connection is not connecting.

  5. #5
    Join Date
    Dec 2008
    Location
    veenwouden
    Posts
    2,558

    Default



    Interested in 6-12W RGB projectors with low divergence? Contact me by PM!

  6. #6
    Join Date
    Feb 2015
    Posts
    1

    Default

    I hooked up everything again, and guess what. It worked. - but, as soon as i touched the controllercard for the Y galvo it started to pulse again.
    We offer up to date Testking ged online exam practice questions with self paced test engine to help you pass act test prep exam and complete your ccent course kumc you should also find ccnp wireless training for your Northwestern University

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •