Results 1 to 3 of 3

Thread: LaserBoy 07-10-2008 !!!

  1. #1
    Join Date
    Jan 2006
    Location
    Akron, Ohio USA
    Posts
    1,754

    Talking LaserBoy 07-10-2008 !!!

    Hey everyone!

    Here's a new version with some (beta) features.

    http://hacylon.case.edu/laser/LaserBoy/LaserBoy_07_10_2008.zip

    Now you can spilt 6 channel waves into stereo and mono waves for more flexibility and investigations. You can also join waves together into 6 channel waves. It's still a little buggy (like if you dont have end of frame marks in the information you import as the red... Ugh!) and it has exposed something else that needs to be fixed. It is only possible to _delay_ (as in lag behind... negative numbers of samples) the color tracks from the position tracks. That makes sense, since that is what needs to be done anyway... but I like for my math to be truly academic and work both ways, like it should! Now there is also a way to force a new set of offsets into a LaserBoy wave header, in case you get something that isn't time aligned, you can figure out what the shifts are and set them in the header without actually shifting the data. This creates a gaurenteed crash if you overwrite with any positive numbers or create situations where the position is delayed from the colors.

    This is all going to take some time and experimentation to get sorted out, but It seems to be moving in the right direction.

    Any comments or suggestions would be greatly appreciated!

    Thanks!

    EDIT: Duh! I forget to put the directory "split" inside the "waves" directory!

    James.
    Last edited by James Lehman; 07-11-2008 at 10:59.

  2. #2
    Join Date
    Oct 2006
    Location
    Cleveland, Ohio
    Posts
    2,334

    Default

    When I tested 7-9-2008 I was able to delay and advance the color timing relative to the position timing, no problem. The waveform info display just liked to show negative numbers, but it was working, and displaying correctly because for advanced color, the 0 index was color, for delayed color, the 0 index was position.

  3. #3
    Join Date
    Jan 2006
    Location
    Akron, Ohio USA
    Posts
    1,754

    Default

    Both drlava and my friend Dean have pointed out bugs. It seems like some information that should be blank is getting unblanked and it shows up in the wave output as a possible unoptimized long jump. It definaitely makes my scanners chirp!

    I just hope that the two different problems are cause by the same thing!

    James.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •